Master script for NetStumbler 0.4

Take a script, leave a script - Like the penny tray only different

Postby goldfndr » Mon Jul 17, 2006 6:12 pm

Well... if you (or someone else) can come up with a technique that further reduces (eliminates) the pauses, I'd be happy to try to implement it.

In other news, I've added some logging support - it can create a debugging log file, and can read said log back in with event processing (e.g. listen to the SSIDs that were detected). One thing I observed, cp99, is that the OnGPS* functions aren't called if NetStumbler isn't configured to use a GPS. So, I've ripped the "UseGPS" variable and associated functionality out. cp99, was there a specific slow-down you'd observed that led you to believe that GPS functionality was responsible? Or were you just looking to save a couple kilobytes? What was the original reason for your desire to "separate[d] the Speech from the GPS code"?
goldfndr
 
Posts: 181
Joined: Sat Aug 28, 2004 3:30 am
Location: Bellevue, WA, USA

Postby dadaniel » Wed Sep 13, 2006 12:50 am

Mappoint 2006 is out (also german version)... any reports if it's working? :confused:
dadaniel
Mini Stumbler
 
Posts: 15
Joined: Tue May 18, 2004 3:10 am
Location: Austria

Postby goldfndr » Sat Sep 16, 2006 5:04 pm

dadaniel wrote:Mappoint 2006 is out (also german version)... any reports if it's working? :confused:

It's been out for three weeks - surely someone has bought it and tested it by now. And MapPoint 2006 for North America has been out for 4.5 months with no substantiated error reports.

If there are any posted bugs with the script, I'd be happy to take a stab at fixing them, whether they be with MapPoint or otherwise. I can't fix what isn't broken!

Improvements are another thing. Based loosely on [thread=8280]supadave's concept[/thread] (I'm pretty sure I'm not using any of his code), there'll be an additional module ("Status") that outputs files that LCD Smartie can read without plugins. (There's a registry reading plugin for it that could easily use the DiGLE entries, but it requires .NET 2.0.) Other applications could read it (thus "status" instead of "LCD").
For quickest response, catch me on IRC: #wigle
goldfndr
 
Posts: 181
Joined: Sat Aug 28, 2004 3:30 am
Location: Bellevue, WA, USA

Postby markskinner » Sat Oct 21, 2006 11:12 am

I have tried the new script with mappoint 2006 tonight and it seems to working ok, i am only able to test this at home at the mo but i will be going out on the road tommorow to give it a better test. i will report back tommorow night with my findings.
markskinner
Mini Stumbler
 
Posts: 1
Joined: Sat Oct 21, 2006 8:14 am

Postby goldfndr » Sat Jan 20, 2007 9:56 pm

Wow, I hope markskinner survived his night with MapPoint...

New version of the Master Script. A few more modules added.
  • Roadnav support!
    No longer is real time mapping limited to Microsoft MapPoint, now you have a choice. And since it has some preliminary support for OpenStreetMap, you're also not limited to the USA.
    If you already have Roadnav 0.16 with cached maps, it can work, but I highly recommend getting 0.17 beta (it is scheduled for release on 2007-02-01). 0.17 has:
    • fix for icon filenames with "$" in them
    • fix/retension for icon scaling
    • greatly improved rendering performance
    • and, of course, ability to download current TIGER maps (they'd switched from lowercase to uppercase).
    If you plan to use Roadnav then I highly recommend also downloading and installing OstroSoft Winsock Component - the Roadnav scripting engine can execute one command at the command line, but using the Telnet interface is much faster and efficient. If there are free scriptable alternatives to OstroSoft Winsock Component that you'd like supported, post a URL to the API.

  • Logger - recording and playback (no, not lumberjacks).
    If you
    • don't have MapPoint working but want to do tracking later
    • want to listen to the network names as a cure for insomnia
    • are too slowed down by the existing modules (time spent executing modules may be time lost detecting networks, this does multithreading)
    • want to [thread=21168]run multiple instances[/thread] while still supporting the modules you like
    then this is for you. If you plan to use multiple instances then I highly recommend using the [thread=21863]NetStumbler 0.4 Helper[/thread] to store/use multiple configurations. Support specifically for multiple instances should go on [thread=21168]the existing thread[/thread] (unless it's a NetStumbler 0.4 Helper support issue, then it should go on the [thread=21863]Helper's thread[/thread].
    One other nice thing about the playback (simply run "ns04logger.vbs" at the command line) is that greatly improves module debugging/improving - no need to start NetStumbler each time if there's an error-causing log file available. It became very obvious that cp99's request for a UseGPS setting was [post=169864]pointless[/post] (or so I think - cp99 still hasn't replied).

  • Status - support for LCD Smartie and others.
    Inspired by [thread=8280]supadave's code[/thread] (please, no resurrecting the dead), I've added a module that writes a file with the current state that LCD Smartie (or perhaps Microsoft Windows SideShow). If you have your laptop in your backpack, you could run [url=http://palmorb.sf.net/[/url]PalmOrb[/url] on your PalmOS-compatible PDA, like I did when I was taking a bus to training.
    There is some information on doing something similiar with a PPC, if you're interested in this and can figure out how to write an XML file (or other file) that SideShow or whatever can use, post here and I can try to write something for it.
    Why did I do this when the information is retrievable from the registry when UseDiGLE is enabled? LCD Smartie doesn't have native support for reading the registry but it does support reading files.

And of course there are the usual improvements with the possibility of having broken something.

Of course, any feedback is invited. If you're reporting a bug, please see if you can reproduce it in both the latest version and the penultimate version (so I'll know whether it's something I broke or something that might've always been broken). If you'd like something implemented (there are a bunch of other potentially scriptable programs mentioned in ns04settings.vbs:
Future possibilities; might not ever be available; anything desired requires testing by volunteers
so see the list for some examples), I'll need cooperation.

If you like what you see here, please donate to marius. Donations might spur marius to add some additional scripting support.

I'm still at the forum's 5 attachments limit, so I've removed 2004-11-24 from the first posting after 973 "views". If anyone wants it (e.g. for comparing), I've attached it to this message.
Attachments
20041124.zip
(20.71 KiB) Downloaded 314 times
For quickest response, catch me on IRC: #wigle
goldfndr
 
Posts: 181
Joined: Sat Aug 28, 2004 3:30 am
Location: Bellevue, WA, USA

Postby TomSelleck » Sun Jan 21, 2007 11:07 am

I have read the entire thread. I am still getting an error when launching NS:

ns04master
CrumbSymbol is not numeric:
c:\Program Files\Network Stumbler\CIcons\blue.gif
Mappoint support deactivated.


I have MapPoint 2006 installed.
I am using the scripts from the 2007-01-20 zip. I extracted them to the c:\program files\network stumbler folder. I created a CIcons subfolder. Where do I get the files that go in the CIcons folder?
TomSelleck
Mini Stumbler
 
Posts: 1
Joined: Sun Jan 21, 2007 8:33 am

Postby goldfndr » Thu Jan 25, 2007 1:57 am

TomSelleck wrote:I have read the entire thread. I am still getting an error when launching NS:

ns04master
CrumbSymbol is not numeric:
c:\Program Files\Network Stumbler\CIcons\blue.gif
Mappoint support deactivated.


I have MapPoint 2006 installed.
I am using the scripts from the 2007-01-20 zip. I extracted them to the c:\program files\network stumbler folder. I created a CIcons subfolder. Where do I get the files that go in the CIcons folder?

Um... let me guess, you didn't think to examine your CrumbSymbol setting? And check whether or not it was numeric? BTW, post #1 mentions Icons, you should take another look at it.

Just for the less clueful, I've added a new feature: it checks all used settings and makes sure that they're mostly valid. So TomSelleck's error should be more like this:
Error: The following setting in "C:\Program Files\Network Stumbler\ns04settings.vbs" is invalid:

CrumbSymbol, "C:\Program Files\Network Stumbler\Cicons\blue.gif", seems to be of type "String" but it needs to be a small (<256) nonnegative number.

Mappoint support deactivated.
If there's a clearer way to word this, let me know.

A few of the oddball ones (e.g. UseThreading has a range of -2 to 2) aren't checked very well, and I'm not sure how much checking is worthwhile. Some of the files have relative paths, and some have absolute paths - I wasn't sure whether to check the scripts folder or NetStumbler's folder. Maybe in the future I'll have it check both for files that need to exist (e.g. ns04events.vbs) to reduce copies. Or maybe not. Any preferences?

There's another feature: if there's a file named ns04immed.vbs in the scripts folder, it'll be executed when Scanning is enabled or disabled (i.e. press the triangle or type Ctrl+B). This may be useful if the script is running and you want to take advantage of something or stop doing some processing without entirely clearing any "dictionaries" in memory.

There were several minor bugs that I somehow missed - feel free to compare if you'd like.

The attached file had 9 downloads before I pulled it from post #1. No telling how many more there will be.
Attachments
20070120.zip
(46.73 KiB) Downloaded 404 times
For quickest response, catch me on IRC: #wigle
goldfndr
 
Posts: 181
Joined: Sat Aug 28, 2004 3:30 am
Location: Bellevue, WA, USA

Postby goldfndr » Fri Jan 26, 2007 9:50 pm

Alas, there are a couple of minor edits to make. Line 453, which starts out as Case vbByte, needs to have the next line:
If IsNumeric(vval) and CByte(vval) = vval Then Exit Function
changed to:
If IsNumeric(vval) Then
If CByte(vval) = vval Then Exit Function
End If
to work properly. I don't know why I'm not able to use "and" in there, it must be a BASIC quirk.
For quickest response, catch me on IRC: #wigle
goldfndr
 
Posts: 181
Joined: Sat Aug 28, 2004 3:30 am
Location: Bellevue, WA, USA

Postby beakmyn » Sat Jan 27, 2007 8:01 am

goldfndr wrote:Alas, there are a couple of minor edits to make. Line 453, which starts out as Case vbByte, needs to have the next line:changed to:to work properly. I don't know why I'm not able to use "and" in there, it must be a BASIC quirk.


VB will allow to skip the endif but it's always a good idea to put them in since you never know what a Microsoft product might do. ;)
beakmyn
 
Posts: 4858
Joined: Sun Aug 03, 2003 1:53 pm

Postby andbad » Sat Feb 17, 2007 3:46 pm

hi, i have a problem
i set this script with a gps and mappoint 06 and all run done, but mappoint don't center the current position on the map (the icon of the car go out from the screen) if i set the CentreVehicle const to 0, 1 or more. If i set -1 or less, the program center me on the map, but zoom out to unacceptable view every second. I search on the forum but i found nothing.
Can i do?
Thanks (and sorry for my english)

By(t)e
andbad
Mini Stumbler
 
Posts: 3
Joined: Tue Feb 06, 2007 9:40 am

Postby andbad » Wed Feb 21, 2007 4:43 am

someone can help me?

By(t)e
andbad
Mini Stumbler
 
Posts: 3
Joined: Tue Feb 06, 2007 9:40 am

Postby beakmyn » Wed Feb 21, 2007 5:34 am

andbad wrote:hi, i have a problem
i set this script with a gps and mappoint 06 and all run done, but mappoint don't center the current position on the map (the icon of the car go out from the screen) if i set the CentreVehicle const to 0, 1 or more. If i set -1 or less, the program center me on the map, but zoom out to unacceptable view every second. I search on the forum but i found nothing.
Can i do?
Thanks (and sorry for my english)

By(t)e



The script is probably looking for a True or False in VB
True = -1
False = 0

Don't know about the zoom that may be a setting in your mapping program to zoom out to a certain extent to show position.
beakmyn
 
Posts: 4858
Joined: Sun Aug 03, 2003 1:53 pm

MapPoint '06 Not Plotting

Postby reuanah » Tue Feb 27, 2007 6:25 am

Greetings, I'm having a problem with Mappoint not plotting anything.

Using DeLorme BT-20, MapPoint 2006 US, and NS 0.4.0.

After configuring my GPS and enabling the UseMappoint variable in the settings VBScript, launching NS will auto-launch Mappoint fine but no WAPs are plotted and Last Location shows as the default Deer Park TX.

My coordinates are showing up in the status bar of NS, and for each discovered WAP so I believe my GPS is functioning properly.

Any ideas?

Thanks in advance.
reuanah
Mini Stumbler
 
Posts: 1
Joined: Mon Feb 26, 2007 3:36 pm

Postby julakali » Sun Mar 04, 2007 10:08 am

Same Problem here.
No Waypoints in Mappoint 2004, although it is automatically started an i can't see any errors.
julakali
Mini Stumbler
 
Posts: 2
Joined: Sat Mar 03, 2007 4:53 pm

Postby goldfndr » Mon Mar 05, 2007 1:06 am

Question to those with MapPoint: Do either of the 2006 versions work for waypoints or centering? You should be able to swap ns04mappoint.vbs 20060629 vs 2007 with the following exceptions:
  • Add or remove the BestSNR parameter to the OnScanCompleteMappoint subroutine.
  • Add or remove the Distance function.
Let me know what you find, and I'll try to dig further. Also, please enable track drawing (WriteTrack) and crumb trails (DropCrumbs), let me know if those work.


beakmyn: CentreVehicle is defined in ns04settings.vbs as:
'0 = never, 1 = always, >1 = within square (half side), <0 = within circle (radius)
I find it a bit shocking that VB has looser syntax than VBscript. Skipping the endif! Or is that "end if" (as VBscript uses)?
For quickest response, catch me on IRC: #wigle
goldfndr
 
Posts: 181
Joined: Sat Aug 28, 2004 3:30 am
Location: Bellevue, WA, USA

PreviousNext

Return to Scripts

Who is online

Users browsing this forum: No registered users and 1 guest